1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Trouble Logging In or Staying Logged In?

    CLEAR YOUR BROWSER COOKIES! More info about this can be found here. If you still have trouble after clearing your browser's cookies and cache, reply to that thread and tell us what browser you're using and what device you're using.

2G Sylvania Headlights?? Has anyone used them

Posted by kulalulualien, Dec 6, 2018 at 10:06 AM

Please Support STM Tuned
Tags:
  1. kulalulualien

    kulalulualien Probationary Member

    4
    0
    Joined Nov 27, 2018
    Wauconda, Illinois
    Hello, i'm a new DSM owner and recently picked up some new headlight bulbs (low beam) but cant get them to clip into the connector for the life of me. I went back to the auto parts store and had them double check to make sure i got the right ones but it seems I did. Has anyone used this brand before?
     

    Log in/Register to remove ads

    Featured Products from our Supporting Vendors

  2. Techn0Nut1996

    Techn0Nut1996 Proven Member

    58
    9
    Joined Jan 20, 2017
    Ames, Iowa
    Did you buy a 9006 bulb? I have not sued this brand on a DSM before but I did have them in my old Galant with no issues, if they are the right size they should fit fine.
    Also, what connector are you referring to? The bulb into the housing or the wires into the bulb itself?
     
    My DSM:
    Loading...
  3. kulalulualien

    kulalulualien Probationary Member

    4
    0
    Joined Nov 27, 2018
    Wauconda, Illinois
    yeah i got the 9006 ones. and im trying to get the bulb to connect ot the wires.
     
  4. Techn0Nut1996

    Techn0Nut1996 Proven Member

    58
    9
    Joined Jan 20, 2017
    Ames, Iowa
    It should just slide in and click in place. I'm not sure what would be hindering you from doing that as long as you are inserting the connectors in the correct direction. Keep trying, you should get it. If all else fails post a decent clear picture of the bulb and the connector and see if anyone else has any input/ notices anything thats off.
     
    My DSM:
    Loading...
  5. dustyboner

    dustyboner Proven Member

    615
    186
    Joined Mar 13, 2016
    abq, New Mexico
    I have run the sylvania silver star bulbs since the came out. Are you sure you didnt pull out the high beam by accident? The low beams are in the center of the headlight, they have a white plug, high beams have a black plug
    DSC04519.JPG DSC04520_cr.jpg
     
    Last edited: Dec 6, 2018 at 4:03 PM
    1990TSIAWDTALON likes this.
  6. kulalulualien

    kulalulualien Probationary Member

    4
    0
    Joined Nov 27, 2018
    Wauconda, Illinois
    That might acctually be my problem. Ill double check that when i get back from work. Thank you
     
  7. kulalulualien

    kulalulualien Probationary Member

    4
    0
    Joined Nov 27, 2018
    Wauconda, Illinois
    Ok thank you. i was trying to attach the low beam to the high beam port. thnx for the help yall
     

Share This Page

Loading...


Log in/Register to remove this ad

Support Vendors who Support the DSM Community
Ace Race Parts Archer Fabrication Best Used Tires Boostin Performance ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RockAuto SouthBay Fuel Injectors STM Tuned Tire Rack VR Speed Factory White Shed Speed